Tag Archives: network printing

Linkstation Windows Printing Problem “Solved”

[edit: Coshy has kindly shared Windows 7 information on this; please see the comments for this post below.]

We have a Buffalo Linkstation Live NAS, model HS-DH500GL hanging off our home network serving personal files. The unit includes a print server. You hook up a USB printer, and it works. And for most of the first year, it was flawless.

Then, at some point in 2008, it stopped printing. Or, rather, it stopped printing from Windows. In the case of this particular printer, it’s shared on one local network here consisting predominately of Windows and Linux computers; the odd thing is that we could still print from any random Linux box we’d attach to the LAN. No PC running Windows would work any longer.

Linkstation-HSDH500GLAnd after probably two months of printing from Windows not working, it suddenly spit out some old stuck docs (roughly two months old or so–I know, right?) and started working again. And it worked again normally for many, many months.

Until a few months ago, when it stopped again. And this time, it’s shown no signs of coming back to life.

And once again, we can still happily print via Linux all day long, like there’s no problem at all. File server functionality (across all OSes that access it) is still totally fine as well.

Digging around, it seems it’s a pretty common problem. These devices (and not just our 500G model, it seems) apparently don’t handle Windows printing very well and, over time, eventually fall over, seemingly dead (from a Windows printing point of view). Documents seem to stick in a print queue somewhere. In our case, on any Windows machine we looked at, the Windows print queue always seemed to show as pending the last print job from whatever Linux box–a print job that we know has printed and been held in our hands.

So those stuck documents…are they really stuck? Attempts to empty spooler folders, restart print services on Windows, monkey with bidirectional-communications settings, etc… nothing worked. XP, Vista, made no difference. We have not tested this with Windows 7, but we assume the problem exists there as well, as it appears it’s a Buffalo/Linkstation problem, and not an issue with Windows itself.

The only apparent solution is to completely wipe everything from the Linkstation device (not just configuration info, but all of your data), monkey with setting the NAS software into a debug mode, and force-updating/overwriting the firmware to “reset” it completely. This resets everything. User data, user configurations, everything. We weren’t about to blow away the data or deal with moving it around if we didn’t have to. If that solution works for you, go for it. Sadly, even this extreme solution does not work for everyone.

We went a different route. Our workaround? Installing Print Services for Unix, under Windows. It’s dead-easy, assuming you have access privileges on your Windows machine, and here’s a Microsoft Knowledge Base (KB) article that tells you how:

Print Services for UNIX: http://support.microsoft.com/kb/324078

You’ll need to install this on each Windows machine that won’t print (likely all of them once this bug rears its head); it can be automated in the normal ways if you have a larger installed base of affected computers.

The normal way Windows users are told to connect to their Linkstation’s print server is via Network Neighborhood. You navigate to your Linkstation device, see the print server, right-click, and choose “Connect…”. That sets up a printer connection. You choose the driver or provide one, and you’re off to the races. If you don’t go that route, you can always add a printer via the Printers control panel and end up with the same result. Only, once it stops printing, good luck printing consistently that way ever again.

Follow the KB article instructions to get Print Services for Unix installed, then configure an LPR port as described, giving either LAN IP or name for your Linkstation, pointing drivers at it, and start printing again.

It doesn’t solve the problem of Windows printing directly, but it does pretty easily solve the more general–and ultimately more useful–“I just wanna print from Windows, but can’t” problem. Hopefully it works for you, too. We wanted to let this run for a few weeks or so without issue before writing it up; so far, so good.

And Buffalo, we shouldn’t have to say it…. but you might want to finally fix this long-standing bug in a way that doesn’t require people to pay for twice the archive/backup hardware they really need (buying another backup/archive solution as temporary or replacement storage altogether).